<!DOCTYPE html> <!--[if lt IE 7 ]><html class="ie ie6"> <![endif]--> <!--[if IE 7 ]><html class="ie ie7"> <![endif]--> <!--[if IE 8 ]><html class="ie ie8"> <![endif]--> <!--[if IE 9 ]><html class="ie ie9"> <![endif]--> <!--[if (gte IE 9)|!(IE)]><!--><html><!--<![endif]--><head> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><title>My Twitter comments and (changing) predictions re: the US pandemic &#8211; Sanjeev Sabhlok&#039;s blog</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Sanjeev Sabhlok&#039;s blog &raquo; Feed" href="https://www.sabhlokcity.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Sanjeev Sabhlok&#039;s blog &raquo; Comments Feed" href="https://www.sabhlokcity.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Sanjeev Sabhlok&#039;s blog &raquo; My Twitter comments and (changing) predictions re: the US pandemic Comments Feed" href="https://www.sabhlokcity.com/2020/07/my-twitter-comments-and-changing-predictions-re-the-us-pandemic/feed/" /><style type="text/css" media="all">@font-face{font-family:'Bitter';font-style:italic;font-weight:400;src:local('Bitter Italic'),local('Bitter-Italic'),url(https://fonts.gstatic.com/s/bitter/v15/rax-HiqOu8IVPmn7erxrJDs.woff) format('woff')}@font-face{font-family:'Bitter';font-display:block;font-style:normal;font-weight:400;src:local('Bitter Regular'),local('Bitter-Regular'),url(https://fonts.gstatic.com/s/bitter/v15/rax8HiqOu8IVPmn7f4xv.woff) format('woff')}@font-face{font-family:'Bitter';font-display:block;font-style:normal;font-weight:700;src:local('Bitter Bold'),local('Bitter-Bold'),url(https://fonts.gstatic.com/s/bitter/v15/rax_HiqOu8IVPmnzxKl8AxhZ.woff) format('woff')}@font-face{font-family:'Droid Sans';font-display:block;font-style:normal;font-weight:400;src:local('Droid Sans Regular'),local('DroidSans-Regular'),url(https://fonts.gstatic.com/s/droidsans/v12/SlGVmQWMvZQIdix7AFxXkHNSaw.woff) format('woff')}</style><link rel='stylesheet' id='fvm-header-0-css'  href='https://www.sabhlokcity.com/wp-content/uploads/cache/fvm/1594340717/out/header-22f50edf3b72232f3a24f922da9c43b937fe6dc6.min.css' type='text/css' media='all' /> <script type='text/javascript' src='https://www.sabhlokcity.com/wp-content/uploads/cache/fvm/1594340717/out/header-f0058641a050d28b94dd899c6780665c0c05dbf9.min.js'></script><link rel='https://api.w.org/' href='https://www.sabhlokcity.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sabhlokcity.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sabhlokcity.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='My email to a person still panicking from the pandemic' href='https://www.sabhlokcity.com/2020/07/my-email-to-a-person-still-panicking-from-the-pandemic/' /><meta name="generator" content="WordPress 5.4.2" /><link rel="canonical" href="https://www.sabhlokcity.com/2020/07/my-twitter-comments-and-changing-predictions-re-the-us-pandemic/" /><link rel='shortlink' href='https://www.sabhlokcity.com/?p=60521' /><link rel="alternate" type="application/json+oembed" href="https://www.sabhlokcity.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sabhlokcity.com%2F2020%2F07%2Fmy-twitter-comments-and-changing-predictions-re-the-us-pandemic%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.sabhlokcity.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sabhlokcity.com%2F2020%2F07%2Fmy-twitter-comments-and-changing-predictions-re-the-us-pandemic%2F&#038;format=xml" /> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-7339209681520725",
          enable_page_level_ads: true
     });</script> <script type="text/javascript">$SA = {s:274368, asynch: 1};
(function() {
   var sa = document.createElement("script");
   sa.type = "text/javascript";
   sa.async = true;
   sa.src = ("https:" == document.location.protocol ? "https://" + $SA.s + ".sa" : "http://" + $SA.s + ".a") + ".siteapps.com/" + $SA.s + ".js";
   var t = document.getElementsByTagName("script")[0];
   t.parentNode.insertBefore(sa, t);
})();</script> <style type='text/css'>img#wpstats{display:none}</style><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><!-- Jetpack Open Graph Tags --><meta property="og:type" content="article" /><meta property="og:title" content="My Twitter comments and (changing) predictions re: the US pandemic" /><meta property="og:url" content="https://www.sabhlokcity.com/2020/07/my-twitter-comments-and-changing-predictions-re-the-us-pandemic/" /><meta property="og:description" content="A placeholder post, intended to help me quickly find my main Twitter comments on this subject. Note how my estimate of potential US deaths has reduced drastically from 28 May to 24 June. I prefer b…" /><meta property="article:published_time" content="2020-07-10T01:01:43+00:00" /><meta property="article:modified_time" content="2020-07-10T01:02:37+00:00" /><meta property="og:site_name" content="Sanjeev Sabhlok&#039;s blog" /><meta property="og:image" content="https://s0.wp.com/i/blank.jpg" /><meta property="og:locale" content="en_GB" /><!-- End Jetpack Open Graph Tags --><meta name="twitter:widgets:link-color" content="#000000"><meta name="twitter:widgets:border-color" content="#000000"><meta name="twitter:partner" content="tfwp"><style type="text/css" id="modern-business-theme-customizer">/* Content Color */ article.content, footer.post-footer, #post-author { color: #363636; }</style><meta name="twitter:card" content="summary"><meta name="twitter:title" content="My Twitter comments and (changing) predictions re: the US pandemic"><meta name="twitter:site" content="@sabhlok"><meta name="twitter:description" content="A placeholder post, intended to help me quickly find my main Twitter comments on this subject. Note how my estimate of potential US deaths has reduced drastically from 28 May to 24 June. I prefer being driven by data, and as the facts change, I change my mind. 10 July 2020 1 July 2020 29&hellip;"> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-7339209681520725",
          enable_page_level_ads: true
     });</script> </head><body lang="en-GB" class="post-template-default single single-post postid-60521 single-format-standard"><!-- Header	--> <header class="cf"> <!-- Top Navigation  --> <nav class="nav-container top-nav"><div class="in"><ul id="top-nav" class="top-nav secondary-nav menu"><li id="menu-item-41224" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-41224"><a href="http://sabhlokcity.com/">Home</a><ul class="sub-menu"><li id="menu-item-41226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41226"><a href="https://www.sabhlokcity.com/about/">Disclaimer</a></li></ul></li><li id="menu-item-41225" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41225"><a href="https://www.sabhlokcity.com/who-am-i/">Who am I?</a><ul class="sub-menu"><li id="menu-item-41232" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41232"><a href="https://www.sabhlokcity.com/who-am-i/personal-notes/public-servant-forever-copy-of-original-india-today-article/">Public Servant Forever – copy of original India Today article</a></li><li id="menu-item-41231" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41231"><a href="https://www.sabhlokcity.com/who-am-i/thesabhloks/">Sabhloks</a></li></ul></li><li id="menu-item-41386" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41386"><a href="https://www.sabhlokcity.com/resources-on-freedom/india-can-do-ten-times-better/">India can do TEN times better!</a></li><li id="menu-item-41387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41387"><a href="https://www.sabhlokcity.com/what-would-i-do-as-prime-minister-of-india/"><b>What I would do as Prime Minister</b></a><ul class="sub-menu"><li id="menu-item-41388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41388"><a href="https://www.sabhlokcity.com/what-would-i-do-as-prime-minister-of-india/how-to-remove-corruption-from-india/"><b>Remove corruption</b></a></li></ul></li><li id="menu-item-41227" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41227"><a href="https://www.sabhlokcity.com/my-organisations/">Organisations</a><ul class="sub-menu"><li id="menu-item-41229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41229"><a href="https://www.sabhlokcity.com/my-organisations/freedom-team-of-india-2/">Freedom Team of India</a><ul class="sub-menu"><li id="menu-item-42480" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42480"><a href="https://www.sabhlokcity.com/my-organisations/freedom-team-of-india/liberal-workshop-2014/">Liberal Workshop 2014</a></li></ul></li><li id="menu-item-41228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41228"><a href="https://www.sabhlokcity.com/my-organisations/india-policy-institute/">India Policy Institute</a></li></ul></li><li id="menu-item-55175" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-55175"><a href="https://www.sabhlokcity.com/privacy-policy/">Privacy Policy</a></li></ul></div> </nav><section class="clear"></section><div class="in"> <!--  Logo 	--> <section class="logo-box logo-box-header-cta "><p id="title" class="site-title site-title-no-logo no-logo"> <a href="https://www.sabhlokcity.com" title="Sanjeev Sabhlok&#039;s blog"> Sanjeev Sabhlok&#039;s blog </a></p><p id="slogan" class="slogan "> Thoughts on economics and liberty</p> </section><!--  Header Call to Action --> <aside class="header-cta-container header-call-to-action widgets"> <section id="header-call-to-action-text-2" class="widget header-call-to-action-widget widget_text"><div class="textwidget"><p>I now mostly write on my <a href="https://timesofindia.indiatimes.com/blogs/seeing-the-invisible/"><em>Times of India</em> blog: Seeing the Invisible</a></p><p>And do see my <em>Times of India</em> <a href="https://timesofindia.indiatimes.com/blogs/author/sanjeevsabhlok/">articles</a> (and <a href="https://timesofindia.indiatimes.com/edit-page/Reform-the-bureaucracy/articleshow/2242779.cms">here</a>), also <a href="https://www.news18.com/news/opinion/opinion-to-be-successful-lateral-entry-must-lead-to-the-abolition-of-ias-1776887.html">News18</a>, <em><a href="https://thewire.in/politics/case-for-state-funding-of-elections-on-a-per-vote-basis">The Wire</a></em>.</p></div> </section> </aside><section class="clear"></section><!-- Primary Navigation --> <nav class="primary-nav-container"><ul id="primary-nav" class="primary-nav menu"><li id="menu-item-41244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41244"><a href="https://www.sabhlokcity.com/books/">Writings</a><ul class="sub-menu"><li id="menu-item-41245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41245"><a href="https://www.sabhlokcity.com/books/published-books/">Published books</a></li><li id="menu-item-41247" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41247"><a href="https://www.sabhlokcity.com/books/published-articles/">Published articles</a></li><li id="menu-item-41248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41248"><a href="https://www.sabhlokcity.com/books/unpublished-articles/">Unpublished articles</a></li><li id="menu-item-41246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41246"><a href="https://www.sabhlokcity.com/books/unpublished-books/">Unpublished books</a></li><li id="menu-item-41281" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41281"><a href="https://www.sabhlokcity.com/about/detailed-archive-of-this-blog/">Detailed archive of this blog</a></li><li id="menu-item-41249" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41249"><a href="https://www.sabhlokcity.com/books/my-last-testament/">My last testament</a></li></ul></li><li id="menu-item-41250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41250"><a href="https://www.sabhlokcity.com/videos/">Videos, podcasts</a></li><li id="menu-item-41255" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41255"><a href="https://www.sabhlokcity.com/views-on-specific-topics/critical-thinking/">Critical thinking</a><ul class="sub-menu"><li id="menu-item-41257" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41257"><a href="https://www.sabhlokcity.com/views-on-specific-topics/critical-thinking/scientific-method/">Scientific method</a></li><li id="menu-item-41258" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41258"><a href="https://www.sabhlokcity.com/views-on-specific-topics/ignorance/">Ignorance and arrogance of “experts”</a></li><li id="menu-item-41256" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41256"><a href="https://www.sabhlokcity.com/views-on-specific-topics/critical-thinking/mathematics/">Mathematics</a></li><li id="menu-item-41259" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41259"><a href="https://www.sabhlokcity.com/views-on-specific-topics/leaders-fools-knaves/">Leaders, fools, knaves</a></li></ul></li><li id="menu-item-41251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41251"><a href="https://www.sabhlokcity.com/views-on-specific-topics/">Views on topics</a><ul class="sub-menu"><li id="menu-item-41252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41252"><a href="https://www.sabhlokcity.com/views-on-specific-topics/policy/">Policy</a></li><li id="menu-item-41253" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41253"><a href="https://www.sabhlokcity.com/views-on-specific-topics/about-india/">India</a></li><li id="menu-item-41254" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41254"><a href="https://www.sabhlokcity.com/views-on-specific-topics/china/">China</a></li><li id="menu-item-41262" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41262"><a href="https://www.sabhlokcity.com/views-on-specific-topics/god/">God</a></li><li id="menu-item-41261" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41261"><a href="https://www.sabhlokcity.com/views-on-specific-topics/racism/">Racism</a></li><li id="menu-item-41260" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41260"><a href="https://www.sabhlokcity.com/views-on-specific-topics/climate/">Climate</a></li></ul></li><li id="menu-item-41269" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41269"><a href="https://www.sabhlokcity.com/resources-on-freedom/">RESOURCES ON FREEDOM</a><ul class="sub-menu"><li id="menu-item-41276" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41276"><a href="https://www.sabhlokcity.com/resources-on-freedom/quotations-on-liberty/">Quotations on liberty</a></li></ul></li><li id="menu-item-41238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41238"><a href="https://www.sabhlokcity.com/who-am-i/personal-notes/">Personal Notes</a><ul class="sub-menu"><li id="menu-item-55485" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55485"><a href="https://www.sabhlokcity.com/words-to-live-by/">Words to live by</a></li><li id="menu-item-41242" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41242"><a href="https://www.sabhlokcity.com/who-am-i/on-facebook/">On Facebook</a><ul class="sub-menu"><li id="menu-item-49186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49186"><a href="https://www.sabhlokcity.com/who-am-i/on-facebook/pages/">Pages</a></li><li id="menu-item-49185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49185"><a href="https://www.sabhlokcity.com/who-am-i/on-facebook/groups/">Groups</a></li></ul></li><li id="menu-item-41237" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41237"><a href="https://www.sabhlokcity.com/who-am-i/on-directories/">On directories</a><ul class="sub-menu"><li id="menu-item-41235" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41235"><a href="https://www.sabhlokcity.com/who-am-i/common-misspellings-of-my-name/">Common misspellings of my name</a></li></ul></li><li id="menu-item-41241" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41241"><a href="https://www.sabhlokcity.com/who-am-i/subdomains/">Subdomains</a><ul class="sub-menu"><li id="menu-item-41236" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41236"><a href="https://www.sabhlokcity.com/who-am-i/keywords-that-lead-to-this-website/">Keywords that lead to this website</a></li><li id="menu-item-41240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41240"><a href="https://www.sabhlokcity.com/who-am-i/seo-tools/">SEO tools</a></li></ul></li></ul></li><li id="menu-item-55176" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-55176"><a href="https://www.sabhlokcity.com/privacy-policy/">Privacy Policy</a></li></ul> <button class="mobile-nav-button"> <img src="https://www.sabhlokcity.com/wp-content/themes/modern-business/images/menu-icon-large.png" alt="Toggle Navigation" /> <img class="close-icon" src="https://www.sabhlokcity.com/wp-content/themes/modern-business/images/close-icon-large.png" alt="Close Navigation" /> Navigation </button><ul id="mobile-menu" class="menu mobile-menu mobile-nav"><li class="menu-item menu-label primary_nav_label">middle menu</li><li class="menu-item "><a href="https://www.sabhlokcity.com/books/">Writings</a></li><li class="menu-item "><a href="https://www.sabhlokcity.com/videos/">Videos, podcasts</a></li><li class="menu-item "><a href="https://www.sabhlokcity.com/views-on-specific-topics/critical-thinking/">Critical thinking</a></li><li class="menu-item "><a href="https://www.sabhlokcity.com/views-on-specific-topics/">Views on topics</a></li><li class="menu-item "><a href="https://www.sabhlokcity.com/resources-on-freedom/">RESOURCES ON FREEDOM</a></li><li class="menu-item "><a href="https://www.sabhlokcity.com/who-am-i/personal-notes/">Personal Notes</a></li><li class="menu-item "><a href="https://www.sabhlokcity.com/privacy-policy/">Privacy Policy</a></li><li class="menu-item menu-label top_nav_label">new</li><li class="menu-item "><a href="http://sabhlokcity.com/">Home</a></li><li class="menu-item "><a href="https://www.sabhlokcity.com/who-am-i/">Who am I?</a></li><li class="menu-item "><a href="https://www.sabhlokcity.com/resources-on-freedom/india-can-do-ten-times-better/">India can do TEN times better!</a></li><li class="menu-item "><a href="https://www.sabhlokcity.com/what-would-i-do-as-prime-minister-of-india/"><b>What I would do as Prime Minister</b></a></li><li class="menu-item "><a href="https://www.sabhlokcity.com/my-organisations/">Organisations</a></li><li class="menu-item "><a href="https://www.sabhlokcity.com/privacy-policy/">Privacy Policy</a></li></ul> </nav></div> </header><!-- Content --><div class="in"> <section class="content-wrapper post-content single-content cf"> <article class="blog-content content cf"> <section id="post-60521" class="post cf post-60521 type-post status-publish format-standard hentry category-current-affairs"> <article class="post-content"> <section class="post-title-wrap cf post-title-wrap-no-image"><p class="post-date">10th July 2020</p><h1 class="post-title page-title">My Twitter comments and (changing) predictions re: the US pandemic</h1> </section><div class="twitter-share"><a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.sabhlokcity.com%2F2020%2F07%2Fmy-twitter-comments-and-changing-predictions-re-the-us-pandemic%2F&#038;via=sabhlok" class="twitter-share-button" data-size="large">Tweet</a></div><p>A placeholder post, intended to help me quickly find my main Twitter comments on this subject. <span style="color: #ff0000; background-color: #ffff00;"><strong>Note how my estimate of potential US deaths has <span style="text-decoration: underline;">reduced</span> drastically from 28 May to 24 June.</strong></span> I prefer being driven by data, and as the facts change, I change my mind.</p><p><strong>10 July 2020</strong></p><div class="twitter-tweet"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">USA is probably seeing a tiny ripple (not second wave!) now, but there is no evidence that covid survivors (who constitute 99.96% of the US population) face a risk greater than from common cold now &#8211; age-based risks remain &#8211; so elderly should take *normal* precautions. <a href="https://t.co/VPMJJWm4Ue">https://t.co/VPMJJWm4Ue</a></p><p>&mdash; Sanjeev Sabhlok, Pope @Church of Reason &amp; Liberty (@sabhlok) <a href="https://twitter.com/sabhlok/status/1281379608391106562?ref_src=twsrc%5Etfw">July 10, 2020</a></p></blockquote></div><p><strong>1 July 2020</strong></p><div class="twitter-tweet"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">Relax. The pandemic has almost ended in USA. Fauci doesn&#39;t know a *single* thing about viruses or pandemics.</p><p>And FDA&#39;s approval for vaccine will allegedly be given even if it is only 50% better than placebo. These experts have shot themselves in the foot.</p><p>&mdash; Sanjeev Sabhlok, Pope @Church of Reason &amp; Liberty (@sabhlok) <a href="https://twitter.com/sabhlok/status/1278073401802780672?ref_src=twsrc%5Etfw">June 30, 2020</a></p></blockquote></div><p><strong>29 June 2020</strong></p><div class="twitter-tweet"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">At this stage USA is past the pandemic, with 300 covid deaths per day compared with 7,600 normal daily deaths. A vaccine is no longer necessary.</p><p>Previous vaccines have already contributed to trained immunity.</p><p>&mdash; Sanjeev Sabhlok, Pope @Church of Reason &amp; Liberty (@sabhlok) <a href="https://twitter.com/sabhlok/status/1277597738805243904?ref_src=twsrc%5Etfw">June 29, 2020</a></p></blockquote></div><p><strong>27 June 2020</strong></p><div class="twitter-tweet"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">The data: 1) Tests/day are rapidly increasing. 2) Positives out of those tested (1/17) remain lower than when the pandemic started, and way lower than the peak (1/5 &#8211; when herd immunity was achieved in USA in mid-April).</p><p>Why? See last 2 articles: <a href="https://t.co/kVc2nFs7t6">https://t.co/kVc2nFs7t6</a> <a href="https://t.co/nJQ0N7RmyV">pic.twitter.com/nJQ0N7RmyV</a></p><p>&mdash; Sanjeev Sabhlok, Pope @Church of Reason &amp; Liberty (@sabhlok) <a href="https://twitter.com/sabhlok/status/1276659067717423104?ref_src=twsrc%5Etfw">June 26, 2020</a></p></blockquote></div><div class="twitter-tweet"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">He&#39;s right about tests. Only those being hospitalized need to be tested. That&#39;s what Sweden said and didm There are also many other good reasons why USA doesn&#39;t need widespread testing any more &#8211; its pandemic is over and tests merely cause alarm.</p><p>&mdash; Sanjeev Sabhlok, Pope @Church of Reason &amp; Liberty (@sabhlok) <a href="https://twitter.com/sabhlok/status/1276592902206939136?ref_src=twsrc%5Etfw">June 26, 2020</a></p></blockquote></div><p><strong>25 June 2020</strong></p><div class="twitter-tweet"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">Looks like Fauci has managed to scare the markets once again by focusing on cases, not the declining deaths.</p><p>This man is a wily two-timer determined to undermine Trump and USA.</p><p>The biggest mistake of <a href="https://twitter.com/realDonaldTrump?ref_src=twsrc%5Etfw">@realDonaldTrump</a>&#39;s Presidency has been to not throw him out in March itself. <a href="https://t.co/iKzrzvwYKK">pic.twitter.com/iKzrzvwYKK</a></p><p>&mdash; Sanjeev Sabhlok, Pope @Church of Reason &amp; Liberty (@sabhlok) <a href="https://twitter.com/sabhlok/status/1275932119731040256?ref_src=twsrc%5Etfw">June 24, 2020</a></p></blockquote></div><div class="twitter-tweet"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">I&#39;m confident markets will soon realise that the pandemic is nearing its end in the USA and that Trump is *right* to want to open up the world&#39;s largest economy.</p><p>But Democratic governors are determined to decimate the USA economy in order to block a possible Trump re-election.</p><p>&mdash; Sanjeev Sabhlok, Pope @Church of Reason &amp; Liberty (@sabhlok) <a href="https://twitter.com/sabhlok/status/1275933156487524353?ref_src=twsrc%5Etfw">June 24, 2020</a></p></blockquote></div><p><strong>24 June 2020</strong></p><div class="twitter-tweet"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">My ballpark estimate for the final death toll from covid-19 in USA this year is 160k-175k.</p><p>Current deaths are at around 130,000.</p><p>This suggests that the pandemic has largely passed and survivors face an extremely small additional risk. <a href="https://t.co/4OgCT0ifgh">pic.twitter.com/4OgCT0ifgh</a></p><p>&mdash; Sanjeev Sabhlok, Pope @Church of Reason &amp; Liberty (@sabhlok) <a href="https://twitter.com/sabhlok/status/1275789914567610368?ref_src=twsrc%5Etfw">June 24, 2020</a></p></blockquote></div><p><strong>18 June 2020</strong></p><div class="twitter-tweet"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">Not quite. &quot;Cases&quot; are a misleading figure.  Look only at deaths. Ideally at excess deaths. As a lead indicator look at ICU admissions.</p><p>The pandemic is now coming to an end in many parts of USA (e.g. NY). There will be no second wave &#8211; just mild, dampening ripples. <a href="https://t.co/PD0vDJYwO3">pic.twitter.com/PD0vDJYwO3</a></p><p>&mdash; Sanjeev Sabhlok, Pope @Church of Reason &amp; Liberty (@sabhlok) <a href="https://twitter.com/sabhlok/status/1273391539461296128?ref_src=twsrc%5Etfw">June 17, 2020</a></p></blockquote></div><p><strong>28 May 2020</strong></p><ul><li><span style="color: #ff0000;"><strong>in which I grossly over-estimate likely US deaths!</strong></span></li></ul><div class="twitter-tweet"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">Now, in 2020 &#8211;</p><p>San Marino&#39;s COVID pandemic has vanished after killing 0.128% of its population – i.e. COVID has an overall death rate 21 times lower than Spanish flu.</p><p>If COVID in USA has the same lethality as in San Marino, it will kill appx. 420,000 Americans.</p><p>&#8230; 3</p><p>&mdash; Sanjeev Sabhlok, Pope @Church of Reason &amp; Liberty (@sabhlok) <a href="https://twitter.com/sabhlok/status/1265960123043680258?ref_src=twsrc%5Etfw">May 28, 2020</a></p></blockquote></div><p><strong>17 April 2020</strong></p><div class="twitter-tweet"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">The USA&#39;s CDC requires almost all pneumonia fatalities to classified as COVID-19, thus significantly over-reporting pandemic deaths. This is also happening with other causes of death.</p><p>People deserve the true stats.<a href="https://twitter.com/CDCgov?ref_src=twsrc%5Etfw">@CDCgov</a> <a href="https://t.co/XGqxMn04SA">pic.twitter.com/XGqxMn04SA</a></p><p>&mdash; Sanjeev Sabhlok, Pope @Church of Reason &amp; Liberty (@sabhlok) <a href="https://twitter.com/sabhlok/status/1250902007507849217?ref_src=twsrc%5Etfw">April 16, 2020</a></p></blockquote></div><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><section class="clear"></section> <section class="clear"></section> <section class="post-meta"><p> This entry was posted in <a href="https://www.sabhlokcity.com/category/current-affairs/" rel="category tag">Current Affairs</a>.</p> </section> </article> <section class="single-post-navigation post-navigation"> <section class="previous-posts"> </section> <section class="next-posts"> <a href="https://www.sabhlokcity.com/2020/07/my-email-to-a-person-still-panicking-from-the-pandemic/" rel="prev">My email to a person still panicking from the pandemic &raquo;</a> </section> </section> </section><section id="post-author"> <header class="author-header"> <figure class="author-avatar"> <img alt='' src='https://secure.gravatar.com/avatar/eab7a3a03904084c91c77f7b687202eb?s=148&#038;r=g' srcset='https://secure.gravatar.com/avatar/eab7a3a03904084c91c77f7b687202eb?s=296&#038;r=g 2x' class='avatar avatar-148 photo' height='148' width='148' /> </figure><h4>Sanjeev Sabhlok</h4> <a href=""></a> </header><p></p> <a href="https://www.sabhlokcity.com/author/sabhlok-2/">View more posts from this author</a> </section> <section class="clear"></section><section class="after-posts-widgets no-widgets"> </section><section class="clear"></section><section id="comments-container" class="comments-container post-comments post-comments-container cf comments-container-no-comments comments-open"> <section id="comments" class="comments-area no-comments"> <section class="clear"></section><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/07/my-twitter-comments-and-changing-predictions-re-the-us-pandemic/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.sabhlokcity.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='60521' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="6075c140f0" /></p> <script language=javascript src="https://www.sabhlokcity.com/wp-content/plugins/HindiWriter/Parser.js"></script> <script language=javascript src="https://www.sabhlokcity.com/wp-content/plugins/HindiWriter/Hindi.js"></script> <script language=javascript type="text/javascript">function toggleLayer(whichLayer,m)
		{
			var hide = 'Hide Keyboard';
			var show = 'Show Keyboard';
			if (document.getElementById)
			{
				var style2 = document.getElementById(whichLayer).style;
				style2.display = style2.display!='none'? 'none':'';
				document.getElementById(m).firstChild.data = style2.display!='none' ? hide:show;
			}
			else if (document.all)
			{
				var style2 = document.all[whichLayer].style;
				style2.display = style2.display!='none'? 'none':'';
				document.all[m].innerHTML = style2.display!='none' ?  hide:show;
			}
			else if (document.layers)
			{
				var style2 = document.layers[whichLayer].style;
				style2.display = style2.display!='none'? 'none':'';
				document.layers[m].innerHTML = style2.display!='none' ?  hide:show;
			}
		}</script> <div style="display: left;align:left;" id="Hindi"><p style="align:left;"> <label for="lang"><small>Select language:</small></label><input type="radio" value="Hindi" name="language" id="language1" style="width:auto;" onclick="isEng= false;" checked><label for="Hindi"><small>Hindi</small></label>&nbsp;<input type="radio" name="language" id="language2" style="width:auto;" value="English" onclick="isEng= true;"><label for="English"><small>English</small></label> <label for="ChangeLanguage"><small>(Press F12 to change language)</small></label> <small class="commentmetadata"><a href="javascript:toggleLayer('HindiCharacterMap','i');" id="i">Show Keyboard</a></small><div id="HindiCharacterMap" style="display:none;"><img src="https://www.sabhlokcity.com/wp-content/plugins/HindiWriter/HindiMap.JPG" alt="Hindi Character Map"/></div></p></div> <script language="JavaScript" type="text/javascript">var html, urlp;
            var com = document.getElementById("comment");
			var mozilla = document.getElementById&&!document.all;
			if (mozilla)
	            html = com.parentNode.innerHTML;
			else
	            html = com.parentElement.innerHTML;
            var newcomment = new RegExp(html);
            var str = html.replace(/<(\s*)textarea (.*?)>(.*)/i,"<textarea $2 onkeypress=\"if (!isEng){ return change(this,event);} else {return true;}\" onFocus=\"changeCursor(this);\" onClick=\"changeCursor(this);\" onKeyUp=\"changeCursor(this);\" onkeydown=\"positionChange(event);\">$3");
			if (mozilla)
	            com.parentNode.innerHTML = str;
			else
	            com.parentElement.innerHTML = str;
            var url = document.getElementById("comment");
			if (mozilla)
	            urlp = url.parentNode;
			else
				    urlp = url.parentElement;
            var sub = document.getElementById("Hindi");
            urlp.appendChild(sub, url);</script> <p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="234"/></p></form></div><!-- #respond --> </section> </section> </article><!-- Page Sidebar--> <aside class="sidebar widgets"> <section id="primary-sidebar-sds-social-media-widget-3" class="widget primary-sidebar primary-sidebar-widget widget-sds-social-media sds-social-media-widget"> <section class="social-media-icons"> <a href="http://facebook.com/sabhlok/" class="facebook_url fa fa-facebook" target="_blank" rel="me"></a> <a href="https://twitter.com/sabhlok" class="twitter_url fa fa-twitter" target="_blank" rel="me"></a> <a href="http://www.linkedin.com/in/sabhlok" class="linkedin_url fa fa-linkedin" target="_blank" rel="me"></a> <a href="https://www.youtube.com/channel/UCbChOJ0g6FuVvNtpM8HgmVg" class="youtube_url fa fa-youtube" target="_blank" rel="me"></a> <a href="https://www.sabhlokcity.com/feed/" class="rss_url fa fa-rss" target="_blank"></a> </section> <section class="clear"></section></section><section id="primary-sidebar-text-3" class="widget primary-sidebar primary-sidebar-widget widget_text"><h3 class="widgettitle widget-title primary-sidebar-widget-title">GET UPDATES VIA EMAIL</h3><div class="textwidget"><form action="https://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow"><input style="width: 170px;" name="email" type="text" /><input name="uri" type="hidden" value="SanjeevSabhloksBlog" /><input name="loc" type="hidden" value="en_US" /><input type="submit" value="By email" /></form><p><a href="https://feeds.feedburner.com/SanjeevSabhloksBlog"><img style="border: 0;" src="https://feeds.feedburner.com/~fc/SanjeevSabhloksBlog?bg=FFFF66&amp;fg=FF0000&amp;anim=0" alt="" height="26" /></a> | <a href="https://sabhlokcity.com/comments/feed/">Comments RSS</a> | <a href="http://sabhlokcity.com/feed">Direct feed</a></p><hr /><p>Search within this blog: <script async src="https://cse.google.com/cse.js?cx=013138293017280754154:g_hsmpt5b_4"></script></p><div class="gcse-search"></div> <section class="clear"></section> <section id="primary-sidebar-custom_html-2" class="widget_text widget primary-sidebar primary-sidebar-widget widget_custom_html"><div class="textwidget custom-html-widget"><center><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- Responsive-new --> <ins class="adsbygoogle" style="display: block;" data-ad-client="ca-pub-7339209681520725" data-ad-slot="6992632472" data-ad-format="auto"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></center></p><hr noshade="noshade" size="4" /><p>(1) Feel free to republish my posts with attribution: no need to ask. (2) I do not publish sponsored articles &#8211; any such requests will be marked to spam.</p><hr noshade="noshade" size="4" /><p><a href="http://swarnabharat.in/manifesto">Manifesto of the Swarna Bharat Party</a></p><hr noshade="noshade" size="4" /><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- link unit --> <ins class="adsbygoogle" style="display: inline-block; width: 300px; height: 50px;" data-ad-client="ca-pub-7339209681520725" data-ad-slot="6999446072"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p><hr noshade="noshade" size="4" /><p><a href="https://blogs.timesofindia.indiatimes.com/author/sanjeevsabhlok/">My Times of India articles </a> |<a href="https://www.sabhlokcity.com/2018/11/list-of-topics-for-my-future-writer-ups-in-the-times-of-india-online-blog/"> My Times of India blog and planned articles </a></p><hr noshade="noshade" size="4" /></div> </section></div> <section class="clear"></section></section><section id="primary-sidebar-text-4" class="widget primary-sidebar primary-sidebar-widget widget_text"><h3 class="widgettitle widget-title primary-sidebar-widget-title">MY BOOKS AND MANUSCRIPTS</h3><div class="textwidget"><p><center><a href="http://bfn.sabhlokcity.com/"><img src="https://i2.wp.com/www.sabhlokcity.com/wp-content/uploads/2015/11/bfn-small.jpg?fit=780%2C120" data-recalc-dims="1" /><i></i></a></center></p><h3>Breaking Free of Nehru</h3><p>&nbsp;</p><table style="height: 80px;" border="0" width="250"><tbody><tr><td><a href="http://sanjeev.sabhlokcity.com/book1/BFN-fullbook.pdf"><img src="https://i0.wp.com/www.sabhlokcity.com/wp-content/uploads/download-pdf.png?fit=780%2C60" alt="" align="middle" data-recalc-dims="1" /></a></td><td><a href="http://sanjeev.sabhlokcity.com/book1/BFN-sabhlok.epub"><img src="https://i2.wp.com/www.sabhlokcity.com/wp-content/uploads/download-EPUB.png?fit=780%2C60" alt="" align="middle" data-recalc-dims="1" /></a></td></tr></tbody></table><hr noshade="noshade" size="4" /><p><a href="http://sanjeev.sabhlokcity.com/book2/discovery.pdf"><b><i>Discovery of Freedom</i></b> </a></p><p><em><a href="https://www.sanjeev.sabhlokcity.com/Bk/">Becoming Rich and Powerful: A Primer for the Citizens of Pakistan, India and Bangladesh</a></em></p><hr noshade="noshade" size="4" /><p><a href="http://efc.sabhlokcity.com/download-free"><b><i>Seeing the Invisible: A book on economics for children</i></b> </a></p><hr noshade="noshade" size="4" /><p><a href="http://1drv.ms/1qxaTqA"><b><i>Why the IAS must pack up and go</i></b> </a></p><hr width="75%" /><p><b><a href="http://1drv.ms/1gq9ujx"><i>A Free Speech Manifesto</i> </a></b></p><hr noshade="noshade" size="4" /><p><a href="http://1drv.ms/1hikHxJ"><i>Hindu Capitalism</i> </a></p><hr width="75%" /><p><a href="http://1drv.ms/1lJoiG5"><i>Scientific Hinduism Book 1: The role of meat in a healthy diet</i> </a></p><hr width="75%" /><p><a href="http://bit.ly/1jMJpMf"><i>Scientific Hinduism Book 2: Brahminical (caste) Hinduism: a system of institutionalised oppression</i></a></p><hr width="75%" /><p><a href="http://1drv.ms/1kSDrKc"><i>Gandhi, a Marxian Luddite</i></a></p><hr noshade="noshade" size="4" /><p><a href="https://onedrive.live.com/download?resid=CDF444DE552B7D7B%217259"><i>The Truth About Modi</i> </a></p><hr width="75%" /><p><a href="http://1drv.ms/SrOWMI"><i>Modi&#8217;s Lies to the SIT</i> </a></p><hr width="75%" /><p><a href="http://1drv.ms/1kjIuli"><i>Modi&#8217;s criminal spying on Mansi Soni</i> </a></p><hr width="75%" /><p><a href="https://onedrive.live.com/download?resid=CDF444DE552B7D7B!8143&amp;authkey=!AGNbkK9oPYeUXeg&amp;ithint=file%2cdoc"><i>Angrezon Ke Pille (RSS)</i> </a></p><hr width="75%" /><p><a href="https://onedrive.live.com/download?resid=cdf444de552b7d7b!11442&amp;authkey=!AAD6LEsDLMi9iYM&amp;ithint=file%2cdocx"><i>Into India or Out of India? Did Rig Vedic gods and Sanskrit come to India or go out of India?</i> </a></p><hr width="75%" /><p><a href="https://onedrive.live.com/download?resid=CDF444DE552B7D7B%217274"><i>The Truth about Ramdev</i> </a></p><hr noshade="noshade" size="4" /><p><a href="http://1drv.ms/1vV3BiH"> <i>Arvind Kejriwal is a socialist</i></a></p><hr width="75%" /><p><a href="http://1drv.ms/1nCialE"> <i>Arvind Kejriwal&#8217;s Swaraj &#8211; with critical annotations in blue</i></a></p><hr noshade="noshade" size="4" /><p><a href="https://onedrive.live.com/download?resid=CDF444DE552B7D7B!11948&amp;authkey=!AOesa2Qzg4xVxKs&amp;ithint=file%2cdocx"> <i> Islam’s war on liberty: Not just a clash, but a war of civilisations</i></a></p><hr /><p><a href="http://1drv.ms/1pllKSh"> <i>Cost Benefit Analysis and Freedom</i></a></p><hr /><p><a href="http://1drv.ms/1nBRZPx"> <i>Notes on Innovation</i></a></p><hr /><p><a href="http://1drv.ms/1hiCUes"><i>The Glorious Abundance and Creativity of the Robotic Age</i></a></p><hr /><p><a href="http://1drv.ms/1nkzlfU"><i>Dangers of Proportional Representation in India</i></a></p><hr /><p><a href="http://1drv.ms/1p2s5Vl"> <i>Notes on IQ, race, dignity and liberty</i></a></p><hr /><p><a href="http://1drv.ms/RleSIG"> <i>The Net Benefit of CO2</i></a></p></div> <section class="clear"></section></section> <section id="primary-sidebar-recent-posts-3" class="widget primary-sidebar primary-sidebar-widget widget_recent_entries"><h3 class="widgettitle widget-title primary-sidebar-widget-title">Recent posts</h3><ul><li> <a href="https://www.sabhlokcity.com/2020/07/my-twitter-comments-and-changing-predictions-re-the-us-pandemic/" aria-current="page">My Twitter comments and (changing) predictions re: the US pandemic</a> <span class="post-date">10th July 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/07/my-email-to-a-person-still-panicking-from-the-pandemic/">My email to a person still panicking from the pandemic</a> <span class="post-date">2nd July 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/06/while-vedics-might-have-heard-about-the-ocean-they-did-not-practice-ocean-faring-trade-like-the-indus-people/">While Vedics might have heard about the ocean, they DID NOT practice ocean-faring trade like the Indus people</a> <span class="post-date">28th June 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/next-toi-blog-post-and-comments-why-less-than-25-of-the-worlds-population-is-likely-to-get-covid-19/">Next TOI blog post and comments: Why less than 25% of the world’s population is likely to get Covid-19</a> <span class="post-date">31st May 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/covid-19-will-almost-certainly-never-infect-more-than-25-of-the-worlds-population/">COVID-19 will almost certainly never infect more than 25% of the world&#8217;s population</a> <span class="post-date">28th May 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/urgent-herd-immunity-for-covid-19-could-be-as-low-as-15/">URGENT: Herd immunity for COVID-19 could be as low as 15%</a> <span class="post-date">25th May 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/my-next-toi-blog-post-the-effect-of-innate-immunity-cross-reactivity-trained-immunity-and-vitamin-d-on-covid-19/">My next TOI blog post: The effect of innate immunity, cross-reactivity, trained immunity and vitamin D on Covid-19</a> <span class="post-date">24th May 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/notes-on-innate-immunity-particularly-in-relation-to-coronaviruses/">Notes on innate immunity, particularly in relation to coronaviruses</a> <span class="post-date">23rd May 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/if-sunetra-gupta-is-right-then-sweden-uk-and-spain-are-close-to-herd-immunity/">If Sunetra Gupta is right, then Sweden, UK and Spain are close to herd immunity</a> <span class="post-date">22nd May 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/update-swedens-pandemic-has-probably-a-little-more-distance-to-go/">Update: Sweden&#8217;s pandemic has probably (a little) more distance to go</a> <span class="post-date">21st May 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/this-is-the-worst-interference-with-personal-liberty-in-our-history-lord-sumption/">This is the worst interference with personal liberty in our history &#8211; Lord Sumption</a> <span class="post-date">21st May 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/six-reasons-why-there-wont-be-an-economic-depression/">Six reasons why there won’t be an economic depression</a> <span class="post-date">18th May 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/serological-studies-im-ignoring-chelsea-dutch-danish-iran-etc/">Serological studies I&#8217;m ignoring: Chelsea, Dutch, Danish, Iran etc.</a> <span class="post-date">17th May 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/notes-on-the-german-heinsberg-serological-study-ifr-0-37/">Notes on the German (Heinsberg) serological study &#8211; IFR 0.37%</a> <span class="post-date">17th May 2020</span></li><li> <a href="https://www.sabhlokcity.com/2020/05/notes-on-the-miami-dade-serological-study-ifr-upto-0-31/">Notes on the Miami-Dade serological study &#8211; IFR upto 0.31%</a> <span class="post-date">17th May 2020</span></li></ul> <section class="clear"></section></section><section id="primary-sidebar-recent-comments-3" class="widget primary-sidebar primary-sidebar-widget widget_recent_comments"><h3 class="widgettitle widget-title primary-sidebar-widget-title">Recent Comments</h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Anne Sallett</span> on <a href="https://www.sabhlokcity.com/2014/02/one-of-indias-best-school-teachers-mercy-jeyaraja-rao-of-timpany/#comment-1004433">One of India&#8217;s best school teachers, Mercy Jeyaraja Rao of Timpany</a></li><li class="recentcomments"><span class="comment-author-link">Sanjeev Sabhlok</span> on <a href="https://www.sabhlokcity.com/2020/04/can-chloroquine-and-hydroxychloroquine-prevent-covid-19/#comment-1004417">Can chloroquine and hydroxychloroquine prevent/cure COVID-19?</a></li><li class="recentcomments"><span class="comment-author-link">Vijay Kumar</span> on <a href="https://www.sabhlokcity.com/2020/01/conclusive-proofs-that-shiva-and-ganesha-are-not-vedic-gods-this-further-confirms-that-the-vedic-religion-is-foreign-to-india/#comment-1004411">Conclusive proofs that Shiva and Ganesha are NOT Vedic gods. This further confirms that the Vedic religion is foreign to India.</a></li><li class="recentcomments"><span class="comment-author-link">P</span> on <a href="https://www.sabhlokcity.com/2020/04/can-chloroquine-and-hydroxychloroquine-prevent-covid-19/#comment-1004410">Can chloroquine and hydroxychloroquine prevent/cure COVID-19?</a></li><li class="recentcomments"><span class="comment-author-link">Sanjeev Sabhlok</span> on <a href="https://www.sabhlokcity.com/2020/04/can-chloroquine-and-hydroxychloroquine-prevent-covid-19/#comment-1004406">Can chloroquine and hydroxychloroquine prevent/cure COVID-19?</a></li><li class="recentcomments"><span class="comment-author-link">P</span> on <a href="https://www.sabhlokcity.com/2020/04/can-chloroquine-and-hydroxychloroquine-prevent-covid-19/#comment-1004405">Can chloroquine and hydroxychloroquine prevent/cure COVID-19?</a></li><li class="recentcomments"><span class="comment-author-link">Sanjeev Sabhlok</span> on <a href="https://www.sabhlokcity.com/2017/04/a-discussion-with-jayant-bhandari-regarding-the-underlying-causes-of-indias-misery/#comment-1004397">A discussion with Jayant Bhandari regarding the underlying causes of India&#8217;s misery</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://lilarajiva.com' rel='external nofollow ugc' class='url'>lila rajiva</a></span> on <a href="https://www.sabhlokcity.com/2017/04/a-discussion-with-jayant-bhandari-regarding-the-underlying-causes-of-indias-misery/#comment-1004395">A discussion with Jayant Bhandari regarding the underlying causes of India&#8217;s misery</a></li><li class="recentcomments"><span class="comment-author-link">kaivalya</span> on <a href="https://www.sabhlokcity.com/2013/08/shankara-learnt-advaita-from-a-low-caste-chandala-but-he-never-really-got-the-point-did-he/#comment-1004390">Shankara learnt Advaita from a &#8220;low caste&#8221; Chandala, but he never really got the point, did he?</a></li><li class="recentcomments"><span class="comment-author-link">Sanjeev Sabhlok</span> on <a href="https://www.sabhlokcity.com/2020/01/conclusive-proofs-that-shiva-and-ganesha-are-not-vedic-gods-this-further-confirms-that-the-vedic-religion-is-foreign-to-india/#comment-1004389">Conclusive proofs that Shiva and Ganesha are NOT Vedic gods. This further confirms that the Vedic religion is foreign to India.</a></li></ul><section class="clear"></section></section> </aside> </section></div><!-- Footer --> <footer id="footer"><div class="in"> <section class="footer-widgets-container cf"> <section class="footer-widgets cf no-widgets"> </section> </section><section class="copyright-area no-widgets"> </section><p class="copyright"> <span class="site-copyright"> Copyright &copy; 2020 <a href="https://www.sabhlokcity.com">Sanjeev Sabhlok&#039;s blog</a>. All Rights Reserved. </span> <span class="slocum-credit"> <a href="https://slocumthemes.com/wordpress-themes/modern-business-free/">Modern Business by Slocum Studio</a> </span></p></div> </footer> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle"
style="display:block"
data-ad-format="autorelaxed"
data-ad-client="ca-pub-7339209681520725"
data-ad-slot="7270050872"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> <script type="text/javascript">// 
				jQuery( function( $ ) {
					// Mobile Nav
					$( '.mobile-nav-button' ).on( 'touch click', function ( e ) {
						e.stopPropagation();
						$( '.mobile-nav-button, .mobile-nav' ).toggleClass( 'open' );
					} );

					$( document ).on( 'touch click', function() {
						$( '.mobile-nav-button, .mobile-nav' ).removeClass( 'open' );
					} );
				} );
			//</script> <script type='text/javascript' src='https://www.sabhlokcity.com/wp-content/uploads/cache/fvm/1594340717/out/footer-a2cd9b5713560cc813f09dc27babd3ce49ba094e.min.js'></script><script type='text/javascript'>/*  */
window.twttr=(function(w){t=w.twttr||{};t._e=[];t.ready=function(f){t._e.push(f);};return t;}(window));
/*  */</script> <script type="text/javascript" id="twitter-wjs" async defer src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> <script type='text/javascript' src='https://www.sabhlokcity.com/wp-content/uploads/cache/fvm/1594340717/out/footer-78f0ca0872ca04acadfbc34003a36c81355a62be.min.js'></script><script type='text/javascript' src='https://stats.wp.com/e-202028.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7',blog:'14896730',post:'60521',tz:'10',srv:'www.sabhlokcity.com'} ]);
	_stq.push([ 'clickTrackerInit', '14896730', '60521' ]);</script> </body></html>